problema con postgres

    • Piti74
      Piti74
      Oro
      Registro: 04-14-2009 Artículos: 801
      Tengo un problema con la base de datos.... les cuento complete los 1000SP para descargar el elephant hace 1 semana.... lo descargue sin problemas tambien instale la base de datos postgres y todo funciono bien durante tres dias, en el trecer dia abri el elefant y se abrio una ventana diciendome q la base de datos estaba dañada, y lo q hice fue desintalar el postgres, tal cual como lo dice el link Desinstalar PostgreSQL, reinicie el equipo... y volvi a crear la base de datos sin problemas y todo volvio a funcionar normalmente hasta ayer...... Hoy abro el elepant y me sale el mismo problema, base de datos dañada, vuelvo a desintalar el postgres reinicio el equipo y al crear la base de datos me dice " se perdio la conexion con la base de datos" mas informacion Failed to establish a conection tot 127.0.0.1." repito la dsintalacion del postgres y me sale el mismo mensaje.

      Les agradezco de antemano si me pueden ayudar
      saludos!!
  • 7 respuestas
    • UnDeRCoST
      UnDeRCoST
      Bronce
      Registro: 07-17-2009 Artículos: 2
      Hola, iba a poner un post de ayuda, pero visto que tengo el mismo problema que tu ( failed to establish a connection to 127.00.1) a ver si nos dan la solución. Yo no he podido crear la base de datos todavía por ese problema, un saludo.
    • shikeen
      shikeen
      Bronce
      Registro: 09-21-2008 Artículos: 2.113
      Ejecuten manualmente el "postgres.exe" y prueben de nuevo.

      eso debería solucionar el problema, el archivo ese lo encuentran en "C:\Archivos de Programas\Postgres\" en xp o en vista y seven "C:\Program Files\Postgres\"
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Interesante, esta comprobado shikeen? o cada vez que pase de igual habra que desinstalar?

      Saludos
      Jesus
    • shikeen
      shikeen
      Bronce
      Registro: 09-21-2008 Artículos: 2.113
      Un problema que me daba el elephant a mi a veces es ese de "failed to establish a connection to 127.0.0.1", eso quiere decir que no se esta estableciendo la coneccion con el servidor de la base de datos, que es nuestra misma pc (ip:127.0.0.1).

      La aplicacion que hace que se ejecute el servidor es el postgres.exe, que se ejecuta cuando prendes la pc automaticamente (lo puede comprobar en administrador de tareas y buscas el proceso postgres.exe) pero puede ser que no se haya ejecutado, entonces haces la prueba de ejecutarlo automaticamente si en el administrador de tareas no aparece como un proceso en ejecucion.

      Por ejemplo, si abres el HoldeManager y el proceso este no esta abierto, el mismo HM te da la opcion mediante una ventanita que dice que El servidor de base de datos no se encuentra activo, desea ejecutarlo ahora? (algo asi es el mensaje), al darle aceptar lo que hace el HM es ejecutar el postgres.exe, pero el elephant no tiene esta opción por que nos muestra el error y no hay manera de continuar.

      Solo ejecutan ese proceso y vuelven a abrir el elephant, no hace falta desinstalar nada.

      Espero que se haya entendido, alguna duda ?
    • Piti74
      Piti74
      Oro
      Registro: 04-14-2009 Artículos: 801
      hola jesus

      ya tenia desinstalado el postgres... cuando entro a elephant me pide crear una nueva base de datos, lo cual me pide q ingrese el ususario, la clave y el nombre de la base de datos(como te dije anteriormente ya habia hecho el procedimiento de desintalar postgres y crear la base de datos y no habia tenido ningun problama) pero en este momento le doy nuevo nombre de usuario, clave y base de datos le doy ok y sale la ventana "se perdio la conexion con la base de datos".
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      oh claro entiendo, pero yo una ves provoque este problema y no lo pude solucionar haciendolo correr yo...espero ellos tengan suerte.

      Piti74, instalaste el postgres por separado?

      Si no es asi hazlo.

      megaupload - postgres

      Utilicen WinRAR para descomprimir

      Saludos
      Jesus
    • pocho06
      pocho06
      Bronce
      Registro: 04-19-2008 Artículos: 128
      yo estoy teniendo el mismo problema..

      ahora estoy bajando por separado..