Os dejo una ayuda para instalar el postgres

    • Hakku
      Hakku
      Bronce
      Registro: 01-16-2008 Artículos: 336
      Cuando os da cualquier error en la instalación y mas el error de Internal account lookup failure: No se ha efectuado ninguna asignación entre los nombres de cuenta y los identificadores de seguridad.

      Lo que debeis hacer es lo siguiente.

      * Desinstalar completamente todo de nuevo, para ello desinstais la aplicación desde Panel de Control - Agregar o quitar programas (buscais PostgreSQL para eliminarlo); mirar en Panel de control - Cuentas de usuario y si existe 'postgres', a borrarlo; comprobar que no exista la carpeta o directorio 'C:\Documents and Settings\postgres', en otro caso eliminarla; finalmente abris una terminal (Inicio - Ejecutar: cmd) y veis los usuarios existentes en el sistema con la orden: net user, en caso de aparecer el usuario 'postgres' lo debeis eliminar con la orden: net user postgres /del
      * Reiniciar el sistema operativo
      * Crear manualmente el usuario 'postgres', para ello vamos a Panel de control - Cuentas de usuario, y pulsamos en "Crear una cuenta nueva" dándole el nombre postgres. Tras crearlo, lo seleccionamos para crearle una contraseña como por ejemplo micontraseña y cambiaremos su Tipo de cuenta a Limitada.
      * Cerrar sesión, para que aparezca la pantalla de bienvenida y elegir el usuario 'postgres' recién creado.
      * Una vez puesta la contraseña y creado totalmente el usuario, volvemos a cerrar sesión para entrar con nuestro usuario habitual.
      * Volver a proceder con la instalación de PostgreSQL, cuando pregunte en la ventana de Service configuration por el Account name y el Account password, pondremos postgres y la contraseña elegida antes.
      * Continuen la instalación como se explica en las instrucciones.

      Acordaros de la contraseña que pusisteis tambien al instalar el postgres ya que será la que tengais que poner en el elephant una vez quieras loguearte para crear la base de datos.
  • 3 respuestas
    • Hakku
      Hakku
      Bronce
      Registro: 01-16-2008 Artículos: 336
      A ver si alguien comenta si les funciona...xD
    • EulogioJ
      EulogioJ
      Bronce
      Registro: 08-12-2007 Artículos: 1.292
      original de Hakku
      A ver si alguien comenta si les funciona...xD
      A mí sí que me ha servido. Muchísimas gracias :D

      A ver si me puedes ayudar en otra cosilla, que veo que controlas el tema.

      Esto me ha servido para el elephant, instalando el sql 8.3, pero tengo problemas con el PT2. Resulta que cuando lo inicio me dice (hasta ahora no había tenido problemas) que no encuentra la base de datos, como si el SQL no estuviera funcionando. ¿me podrías decir cómo consultar si el SQL va correctamente o no?
    • Hakku
      Hakku
      Bronce
      Registro: 01-16-2008 Artículos: 336
      Si volviste a instalar el sql supongo que tendrás que volver a crear la base de datos para pt2 n?