problema database HM1 al iniciar

  • 5 respuestas
    • kuthulhu
      kuthulhu
      Bronce
      Registro: 06-05-2011 Artículos: 1.566
      Astur probaste en el menu inicio en la carpeta del postgres darle a start server?
    • kuthulhu
      kuthulhu
      Bronce
      Registro: 06-05-2011 Artículos: 1.566
      Ahi te dejo unos datos que encontre por el Google para resolver el problema.

      - Error: Failed to establish a connection to ‘127.0.0.1’ Service 'PostgreSQL Database Server 8.x' (pgsql-8.x) failed to start.
      - Error: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
      - Postgree se paró derrepente.
      - Actualizaste windows y Postgree dejó de funcionar.
      - Cualquier error de Postgree al iniciar el Hold'em Manager.

      El 99% de estos errores son a causa de un firewall o antivirus y de una actualización de windows.

      1.- A continuación enumeraré una serie de pasos que nos pueden solucionar nuestros problemas:
      - Instala la última versión del Hold'em Manager, puedes hacerlo desde aquí: http://www.holdemmanager.com/store/downloads-manuals.php
      - Actualiza tu sistema operativo, incluyendo .Net Framework.
      - Reinicia tu equipo.

      2.- Si esto no ayuda:

      - Pincha en: Inicio > todos los programas > PostgreSQL 8.x > Stop Server
      - Inicio > todos los programas > PostgreSQL 8.x > Start Server

      3.- Seguimos:

      - Entra en C:\Program Files (x86)\PostgreSQL\8.4\data y borra el archivo > postmaster.pid si aparece.

      4.- Añade excepciones al firewall de windows, windows defender o cualquier antivirus / firewall que tengas:

      - Lo primero es desinstalarlos completamente y ver si entonces funciona Postgre. Si lo hace ya sabemos donde estaba el fallo. Recordad DESINSTALARLOS, no sirve sólo desactivarlos.
      - Para que el firewall deje de darnos problemas añadiremos excepciones al puerto 5432 en los siguientes archivos:

      Dentro de C:\Program Files\RVG Software\Holdem Manager:

      > DBControlPanel.exe
      > Holdemmanager.exe
      > HMhud.exe

      Dentro de C:\Program Files\PostgreSQL\8.x\bin:

      > Pg_ctl.exe
      > Postgres.exe

      5.- Desactiva el account control de windows, para hacerlo (abriendo estos archivos como administrador no es necesario > DBControlPanel .exe, HoldemManager.exe, HMHud.exe):

      - En el boton de inicio busca UAC:

      - Pincha en "Cambiar configuración de cuentas de usuario".
      Bájalo al mínimo:

      Si te pide reiniciar, hazlo.
    • josehg
      josehg
      Bronce
      Registro: 11-07-2011 Artículos: 508
      Mírate este hilo, te puede interesar.

      Un saludo.

      conexion postgre SQL.. ayuda por favor
    • asturgoldboy
      asturgoldboy
      Bronce
      Registro: 07-23-2010 Artículos: 5.344
      Gracias a maroto que me paso este link solucione el error y cito textualmente la solucion:

      Failed to establish a connection to `127.0.0.1`.

      original de Maroto77
      He encontrado una solución para este problema recalcitrante. A mí nunca me funcionó, pese a que hacía lo que hay que hacer (desinstalar postgres y elephant, borrar las carpetas, borrar los usuarios, etc). Lo encontré en un hilo de la comunidad inglesa: http://www.pokerstrategy.com/forum/thread.php?threadid=24647

      Esto es lo que hay que hacer siempre, y que a mí nunca me funcionó:

      Originally posted by batmanbg
      I had the same problem when I tried to install PokerStrategy Elephant. Now i will show you how i fixed the problem.

      First step: Uninstall PostgreSQL

      > 1. Open Start menu > Control Panel > Add or Remove Programs and uninstall PostgreSQL
      > 2. Open C:Program Files and delete PostgreSQL folder
      > 3. Open C:Documents and Settings and delete the user created by PostgresSQL - "postgres" by default
      > 4. Delete postgresql from Application data

      - If your menu is classic path will be Start menu > Settings > Control Panel > Add or Remove Programs
      - If you can't find how to delete the user created by PostgreSQL write C:Documents and Settings in your browser or My Computer there are "All users" "Your computer name" and "postgresql" - by default
      - If you can't find Application data write C:Documents and SettingsYOUR COMPUTER NAMEApplication Data in your browser or My Computer


      Second step: Install PostgreSQL

      > 1. Open C:Program FilesPokerStrategyPokerStrategy Elephant and find postgresql-8.3 (not postgresql-8.3-int) or directly write C:Program FilesPokerStrategyPokerStrategy Elephantpostgresql-8.3.msi in My Computer/Your browser.
      > 2. Choose English > Start > Next > Next > Next
      > 3. Service configuration:
      - Service name: PostgreSQL Database Server 8.3
      - Accout name: postgress (make it different from postgres with one s)
      - Account domain: Leave account name like is by default ( account domain = your computer name )
      - Choose account password and verify it then click Next
      > 4. Click yes to create the new account who will be used from elephant.
      > 5. In initialise database cluster change superuser name from postgres to postgress, write your password and then click Next and Finish


      Third step: Enter your new username

      Here you only have to write your new username "postgress" and your password

      If you see "Database was successfully created and is ready for usage" everything might be okay.

      If this works for you leave a comment and sorry for my bad english

      If you still have problems feel free to contact me in skype: stanimirmihov


      Y ésta es la solución adicional para cuando nada de eso sirve, en el caso de Vista y Siete: añadir el localhost a mano en el archivo de configuración.

      Originally posted by Cealin
      Went through this nice guide. But I got still the 127.0.0.1 error. I run Vista by the way.

      After some hours of trial & error, I found a solution at the HM forum, and it worked! :D


      Here it is:

      - go to "C:\Windows\System32\drivers\etc" and open the hosts file with notepad.

      - At the bottom of the file, add the following line (without the quotes): "127.0.0.1 localhost"

      - Save the file, exit and restart your pc.*


      *If you cannot save it to that location, first save it to the desktop, then right-click on it and change the name to only "hosts" (so remove the .txt extension). Then copy&recplace it to the drivers\etc map


      After this little work, my database is working perfect :)
      Y así, tras tres años de penar en el medievo del poker, ya puedo utilizar estadísticas. :facepalm:
    • Pantxo2
      Pantxo2
      Bronce
      Registro: 07-08-2010 Artículos: 12.329
      Hola Astur

      Me alegro que lo solucionarás :)

      y también muchas gracias por la info recibida nos servirá para futuras ocasiones :)

      Saludos¡

      :diamond:P antxo :diamond: