no arranca el hm

    • katenuzo
      katenuzo
      Bronce
      Registro: 04-24-2008 Artículos: 1.167
      Hola, en el intento de optimizar el pc con diversos programas ( antivirus, anti-malwares, optimizador.......) la cagué pero bien :facepalm: . Ahora no me arranca el HM da este error:


      The following error occurred when trying to open the database: Failed to establish a connection to 127.0.0.1


      Doy OK y me sale una ventana del panel de control de la base de datos, pidiendome un numero para poder conectarme al postgers (si no me equivoco). No se que ha cambiado o de donde puedo sacar el nuevo numero en cuestion, he estado mirando en una direccion del postgres install instructions pero no encuentro nada referente al dichoso numero.


      Haber si alguien me puede hechar un cable, un saludo y gracias. :fdrink
  • 9 respuestas
    • neocai85
      neocai85
      Bronce
      Registro: 05-31-2009 Artículos: 4.170
      Hola katenuzo

      ¿Has instalado algun firewall?

      Si no es así, puede que en la optimización que has realizado, se hayan eliminado los permisos de conexión del HM a la base de datos.

      Si me dices que programa antivirus y/o firewall tienes, te daré una respuesta mas acertada.

      Saludos ;)

      neocai85
    • katenuzo
      katenuzo
      Bronce
      Registro: 04-24-2008 Artículos: 1.167
      Hola, el antivirus es el ESET NOD32 y el otro programa es el MALWAREBYTES ANTI-MALWARE . Que creo que es que me ha liado la averia. Digo esto porque al ajecutar el software de pokerstars, por ejemplo, me sale un mensaje de aviso de error referente al malware.

      Realmente estoy mas perdido que el barco del arroz. :D Un saludo y gracias. :fdrink
    • katenuzo
      katenuzo
      Bronce
      Registro: 04-24-2008 Artículos: 1.167
      Hola, he encontrado este post conexion postgre SQL.. ayuda por favor referente ha mi problema lo he intentado pero no me arranca la base de datos, no se si la mejor opcion sea desistalar este postgres y descargar una version mas actual porque tengo la 8.3. ¿que me aconsejas?.

      Un saludo y gracias.
    • neocai85
      neocai85
      Bronce
      Registro: 05-31-2009 Artículos: 4.170
      Hola katenuzo nuevamente

      Deja que mejor le dé un aviso a los compañeros que manejan mejor el HM que seguro serán de mas utilidad que yo.

      Saludos ;)

      neocai85
    • katenuzo
      katenuzo
      Bronce
      Registro: 04-24-2008 Artículos: 1.167
      Gracias por el interes neocai85, agrego esto por si sirve de ayuda.

      Desde panel de contro/herramientas administrativas/servicios, en la pestaña del postgres está como. tipo de inicio: Automatico, pero el estado no viene como: Iniciado, no pone nada. Intento arrancarlo yo y me dá este error:

      no se puede iniciar el servicio Postgres........ en equipo local. Error 1069:no se puede iniciar el servicio debido a un error en el inicio de sesion.


      De momento sigo buscando por el foro algo que me ayude, muchas gracias de nuevo y un saludo. :fdrink
    • katenuzo
      katenuzo
      Bronce
      Registro: 04-24-2008 Artículos: 1.167
      Hola, agrego este mensaje que me pone cuando intento restaurar el servicio desde el postgres






      Un saludo. :fdrink
    • Balzaack
      Balzaack
      Plata
      Registro: 01-24-2010 Artículos: 685
      Katenuzo, por lo que leo mas arriba, veo que tenías la 8.3 corriendo e instalaste ahora la 8.4 encima. corrígeme si me equivoco. Dime además como lo hiciste, te pisugirió actualizar y le diste que si, o instalaste en otro directorio e hiciste un cambio de puertos????

      El error que tienes es un error de permisos de usario.

      Confírmame lo que te pregunto primero y vemos como abordamos lo segundo.

      saludos!!!!
    • katenuzo
      katenuzo
      Bronce
      Registro: 04-24-2008 Artículos: 1.167
      Hola Balzaack, ahora que me doy cuenta sobre las versiones del postgres fuí yo quien me equivoque al poner que tenia la version 8.3, he tenido la 8.4 todo el tiempo.
      El problema lo he solucionado ya, despues de dar mil vueltas hacer todo lo que me han recomendado, no lograba que me iniciase el postgres debido a algun error. He decidido desistalarlo he intalar otro mas actual el 9.1.3 , lo he instalado y todo me funciona bien. Algun problema con el scanturbo y la databasa pero bueno lo gordo esta solucionado.
      Un saludo y gracias. :fdrink
    • Balzaack
      Balzaack
      Plata
      Registro: 01-24-2010 Artículos: 685
      Katenuzo,

      2 cosas, una buena y otra mala...

      1.- La buena: que bueno que lo solucionaste...

      2.- La mala: esa versión de postgres que instalaste no está soportada por hm y te traerá otro tipo de problemas más adelante. Por ejemplo , para los exports, los backups, los purge, el hmsync entre los más importantes.

      tu problema no era de corrupción de database ni nada grave, era solo un tema de permisos del usuario owner del postgres. Es más, ni siquiera era necesario reinstalar el motor de base de datos. Te recomiendo que reinstales la 8.4.

      un abrazo...