HM error al conectar - No conecta el postgres - Solucionado

    • ottobus
      ottobus
      Bronce
      Registro: 04-18-2008 Artículos: 440
      Hola,

      Hasta ayer funcionaba perfectamente. No toqué nada, así que no entiendo qué pasa. Hoy intenté abrir el HM y me salía un error. Actualicé la versión a la 1.11.07b (tenía la 1.11.05) pero el problema persiste.

      Creo que el problema tiene que ver con el postgres, ya que intenté abrir el mismo con pgAdmin III y tampoco pude hacerlo. Al intentar esto, me sale el error que cito a continuación con unas indicaciones. Aclaro que lo único que verifiqué, es que hay respuesta haciendo un ping al 127.0.0.1 y me dice paquetes enviados y recibidos 4 perdidos 0 :f_biggrin: (ni idea que siginifica pero parece que está todo bien).

      Cito lo que me sale al intentar abrir el pgAdmin III:

      El servidor no escucha

      El servidor no acepta conexiones: la librería de conexión reporta
      could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?

      Si usted encuentra esta mensaje, por favor verifique si el servidor que está tratando de contactar esta realmente ejecutando PostgreSQL el el puerto indicado. Verifique si tiene conectividad de red desde su cliente al servidor usando ping herramientas equivalentes. ¿ Está su red / VPN / túnel SSH / cortafuegos configurado correctamente?

      Por razones de seguridad, PostgreSQL no escucha en todas las direcciones IP disponibles en la máquina del servidor inicialmente. Para acceder al servidor desde la red, usted necesita primero habilitar la escucha en la dirección.

      Para los servidores PostgreSQL comenzando con la versión 8.0, esto es controlado utilizando el parámentro "listen_addresses" en el archivo postgresql.conf. Aquí, usted puede sepecificar una lista de direcciones IP donde el servidor debe escuchar , o simplemente usar '*' para escuchar en todas las direcciones IP disponibles. Para servidores anteriores (Versión 7.3 o 7.4), usted necesitará configurar el parámetro "tcpip_socket" como 'true'.

      Usted puede utilizar el editor de postgresql.conf editor incluido en pgAdmin III para editar el archivo de configuración postgresql.conf. Luego de modificar este archivo, necesitará reiniciar el proceso servidor para que los cambios sean efectivos.

      Si usted verifica su configuración pero aún sigue obteniendo este mensaje, sigue siendo poco probable que haya encontrado un fatal comportamiento erróneo de PostgreSQL. Usted probablemente tiene algún problema de conectividad de red de bajo nivel (p.e. configuración del cortafuegos). Por favor verifique esto exhaustivamente antes de reportar una falla a la comunidad PostgreSQL.



      Bueno, esto ya hace 12 hs que empezó. Esperé un tiempo a ver si era un problema global pero veo que soy el único así que si alguien tiene un idea se lo agradeceré.

      El nombre de usuario y contraseña del postgres están almacenados y no toqué nada (postgres - posgrespass). La versión del postgres es la 8.3.

      Gracias por su tiempo.

      Salu2!
  • 8 respuestas
    • dozora
      dozora
      Bronce
      Registro: 06-07-2010 Artículos: 3.605
      Hola ottobus, ¿ has probado a bajarte el postgres de la página oficial y reinstalarlo?. Un saludo ;)
    • KAsFold
      KAsFold
      Bronce
      Registro: 10-01-2008 Artículos: 2.593
      original de dozora
      Hola ottobus, ¿ has probado a bajarte el postgres de la página oficial y reinstalarlo?. Un saludo ;)
      ayer tuve el mismo error e hice lo que te recomienda dozora ,el problema era que no iniciaba el servicio (services.msc o algo asi y me aparecia iniciando pero no terminaba nunca de arrancar) lo único que perdí mi DB así que tengo que copiar todas las manos de nuevo desde HMarchive.
      si sabes como hacer un backup antes de desinstalarlo y volverlo a instalar no te pasara lo que a mi.
      suerte
    • ottobus
      ottobus
      Bronce
      Registro: 04-18-2008 Artículos: 440
      Hola,

      Gracias a ambos por las respuestas.

      Exáctamente eso me sucede KAsFold. El HM queda cargando y después me dice que no puede conectar a 127.0.0.1.

      He seguido los pasos que indica AGPEBRU en el hilo "error HM al cargar" pero ese archivo que hay que editar, yo lo tengo correctamente.

      No probé con desinstalar el postgres. No lo quiero ni tocar. Ya una vez al instalar por primera vez el HM me volvió loco para hacerlo arrancar!

      Bueno, si no puedo arreglarlo lo voy a tener que hacer, pero antes voy a hacer cualquier otra cosa que me digan :facepalm:

      Nuevamente gracias por sus respuestas,

      Salu2!
    • dozora
      dozora
      Bronce
      Registro: 06-07-2010 Artículos: 3.605
      HOla ottobus, he estado buscando un post de alguien que tenía un problema similar al tuyo y que tuvo que reinstalar el postgres para solucionarlo, pero no lo encuentro, pero estoy casi convencido de que va a ser la solución.

      Hay varios post donde se indica como guardar la base de datos, vete echándole un vistazo por si necesitas al final reinstalar el postgres, un saludo :)
    • ghurhy
      ghurhy
      Bronce
      Registro: 09-24-2009 Artículos: 119
      como lo has solucionado? Tengo el mismo problema
    • ottobus
      ottobus
      Bronce
      Registro: 04-18-2008 Artículos: 440
      Hola,

      Justo hoy iba a poner la solución porque ayer no tuve tiempo. Bueno, lo google y encontré unos pasos que seguí hasta que arrancó el Hm.

      Lamentablemente la solución está en el foro de otra escuela de poker y creo que no puedo poner el enlace, así que poné en el google:

      "holdem manager problema de conexión 127.0.0.1" y es el enlace que sale segundo que dice más o menos "FAQ Hold'em Manager - Fallo al intentar establecer la conexión con ..".

      Espero que te sea útil.

      Y aprovecho para agradecer a los que me dieron una mano.

      Salu2!
    • AGPEBRU
      AGPEBRU
      Bronce
      Registro: 04-24-2008 Artículos: 19.676
      Hola ottobus

      Me alegra que lo hayas solucionado!, una disculpa, se me paso este post :( :facepalm:


      Saludos! :nh
    • ghurhy
      ghurhy
      Bronce
      Registro: 09-24-2009 Artículos: 119
      muchisimas gracias ya lo tengo solucionado