Problema con el Elephant

    • Cherry65
      Cherry65
      Bronce
      Registro: 01-10-2008 Artículos: 257
      Apenas entro al elephant me dice que la base de datos es obsoleta y no compatible con elephant. Lo raro es que yo acabo de instalar todo (incluyendo el PostgreSQL). Cuando se importan las manos lo que pasa es que me toma mal la fecha de las manos. Yo tengo las manos guardadas en ingles, pero la fecha me la toma en la forma española, por lo quelas fechas me quedan fuera de rango (no existe un mes 29, por ejemplo, para las manos del 29/12 que me las toma como si fueran del dia 12 del mes 29). Al pasar esto directamente omite la importacion de las manos y me dice que es un error de la base de datos en el campo date/time.

      En resumen, las dos preguntas mias son:

      Porque me paso eso de la base de datos obsoletas, si acabo de instalar el elephant mas nuevo con el postgreSQL?

      Como puedo solucionar lo de la importacion de manos?

      Se que tendria que cambiar la configuracion del campo date/time de la base de datos, pero como?

      Me olvidaba! juego en Poker Stars, la version del elephant es la 0.96 y la de posgres es la que vino con el elephant (8.3 creo)
  • 7 respuestas
    • Cherry65
      Cherry65
      Bronce
      Registro: 01-10-2008 Artículos: 257
      Este error me salto en el log de errores:

      - Message: ERROR: 22008: date/time field value out of range: "28/12/2010 11:45:52 PM"
      - Severity: ERROR
      - Code: 22008
      - BaseMessage: date/time field value out of range: "28/12/2010 11:45:52 PM"
      - Detail:
      - Hint: Perhaps you need a different "datestyle" setting.
      - Position:
      - Where: COPY pse_hands, line 135, column playdate: "28/12/2010 11:45:52 PM"
      - File: .\src\backend\utils\adt\datetime.c
      - Line: 3118
      - Routine: DateTimeParseError
      - ErrorSql: set datestyle to 'iso, mdy'; COPY pse_hands FROM STDIN WITH DELIMITER '|' CSV NULL AS 'NULL' QUOTE AS ''
      - Errors: System.Collections.ArrayList
      - ErrorCode: -2147467259
      - Data: System.Collections.ListDictionaryInternal
      - TargetSite: Boolean MoveNext()
      - HelpLink: <null>
      - Source: Npgsql
      - InnerException: <null><none>
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.537
      Hola Cherry65!

      Pues deja envio el error a nuestros desarrolladores, no habia escuchado de este error anteriormente :( .

      Saludos
      Jesús
    • Cherry65
      Cherry65
      Bronce
      Registro: 01-10-2008 Artículos: 257
      original de Jesus80
      Hola Cherry65!

      Pues deja envio el error a nuestros desarrolladores, no habia escuchado de este error anteriormente :( .

      Saludos
      Jesús
      Bueno muchas gracias. Desinstale todo, lo volvi a instalar, baje distintas versiones del posgres pero nada. Voy a intentar bajar una version anterior a ver si me anda.
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.537
      Vale, cualquier cosa me informas.

      Saludos
      Jesús
    • Cherry65
      Cherry65
      Bronce
      Registro: 01-10-2008 Artículos: 257
      Finalmente, despues de un dia intentando arreglarlo lo logre.
      Primero descargue varias versiones (mas antiguas) del elephant y no, despues varias versiones del postgresql (antiguas y nuevas) y tampoco.
      Resulto ser que el problema era la configuracion de la region de mi pc. Como esta pc es comprada en EEUU, venia con esa region predefinida y nunca la cambie, y yo al instalar postgres la ponia en espanol. Seguramente ahi estaba el problema porque apenas lo cambie anduvo.

      Al final me quede con el postgresql 9 y el elephant 0.96 funcionando bien en windows 7 64 bits.

      Muchas gracias!
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.537
      jeje que cosas, gracias por compartir la solución ;) .

      Saludos
      Jesús
    • german11
      german11
      Bronce
      Registro: 03-10-2009 Artículos: 519
      original de Cherry65
      Finalmente, despues de un dia intentando arreglarlo lo logre.
      Primero descargue varias versiones (mas antiguas) del elephant y no, despues varias versiones del postgresql (antiguas y nuevas) y tampoco.
      Resulto ser que el problema era la configuracion de la region de mi pc. Como esta pc es comprada en EEUU, venia con esa region predefinida y nunca la cambie, y yo al instalar postgres la ponia en espanol. Seguramente ahi estaba el problema porque apenas lo cambie anduvo.

      Al final me quede con el postgresql 9 y el elephant 0.96 funcionando bien en windows 7 64 bits.

      Muchas gracias!
      que hiciste me pasa lo mismo?

      *** edito ***
      muchas gracias

      modificaste el idioma de la notebook a español y listo
      panel de control> config regional y de idioma > opciones regionales
      y walá !!