POstgres/ Elephant

    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      Antes de descargar la última actualización del elephant cometí el error de desinstalar POstgres desde el panel de control, y claro, ahora al iniciar el elephant no me reconoce la base de datos, y si lo reinstalo sigo teniendo el mismo problema. Seguí los paso que dais para borrar POstgres (cmd, etc..) únicamente no pude encontrar nada en documents and settings q borrar.

      Cuando la instalo de nuevo me aparece un error de Secondary Logon is not working.

      Hay alguna manera de que pueda volver a instalar el elephant sin tener que instalar por separado la base? No tngo ninguna mano guardada.

      Gracias
  • 28 respuestas
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Hola mostovax!

      Por ese error que te da, tienes aqui una posible soucion.

      6. Mensaje error: "The 'Secundary Logon' service is not running. This service is required for the installer to initialize the database. Please start this service and try again"

      Solucion: Este error es que el ejecutador de tareas de windows de otro usuario esta desactivado o no esta instalado.

      * entrar como admin de la pc
      * En el icono de mi pc da click derecho y despues elige Administrar en el menu..diriganse a "servicios y aplicaciones" ..despues en Servicios.
      En la ventana de la derecha aparecera una lista, busquen el que diga "Inicio de sesion secundario" den click derecho y elijan "iniciar" y listo.

      Si no esta deberan instalarlo, pero como es componente de windows creo que seria mejor formatear para que se quede bien instalado conforme al widows y pc que usen.

      o

      1.Inicio->Panel de Control->Rendimiento y Mantenimiento->Herramientas Administrativas->Servicios.

      2. En servicios se busca el servicio que se quiere, en este caso "Secondary Logon", que está en español como "Inicio de sesión secundario" y se selecciona.

      3.Se inicia.
      Saludos
      Jesús
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      Gracias Jesús, ya lo había hecho, que antes no me había dado cuenta de tu post sobre errores.

      Ahora instale el Posgres, pero el problema es q después de instalar el elephant, cuando lo abro me pone:

      "No se pudo establecer conexión con la base de datos! Asegúrate de que PostgreSQL está funcionando y que la configuración es correcta".

      PD. Cuando desinstalé el anterior POsgres hizo todos los pasos, menos el de borrar el usuario en c: documents and settings. Porque no lo encontré....

      Cual puede ser mi problema?

      Muchas Gracias!!
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Hola mostovax!

      Te recomendare reinstalar postgres pero con un nuevo nombre de usuario, es probable sea lo que te este dando pelea.

      Saludos
      Jesus
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      Pruebo a instalarlo entonces cambiando lo de account name y en el paso siguiente de la instalación superusername.

      Siempre me pone que el usuario no existe, si deseo crear uno nuevo.
      .... Pero nada, inicio el elephant que ya tengo instalado y el error vuelve a ser el mismo.

      vaya.......
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Hola mostovax!

      Claro, el account name y el superusername debe ser el mismo, despues tienes que ponerle que SI, que te cree la cuenta y despues continuar con la instalacion... y te sigue dando el mismo error?

      Saludos
      Jesus
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      Sisi, todo eso lo hice y el postgres me lo instala perfectamente. El problema es cuando abro el elephant que me da el error que te puse arriba, como si no reconociera la base....

      Por qué desinstalaría el POsgres como un animal!!
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      humm....

      Es la v85?...o que version?

      Saludos
      Jesus
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      no, es la versión 0.69...

      De qué puede ser??
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Bueno entonces te recomiendo actualizar.

      http://elephant.pokerstrategy.com/

      Borra todo, en esta versión postgres se instala correcto con el Elephant.

      Saludos
      Jesús
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      nada, pruebo con la nueva versión, la instalo, y luego con empiezo con el posgres haciendo estos pasos q tu indicaste


      Primero paso..deinstalar postgres:
      1.abrir menu inicio --> panel de control--> agregar quitar programas y lo desinstalamos.
      2. abrir C:/program files/borrar postgres folder.
      3. Abre C:/document and setting/ borra el user creado por postgres.

      Segundo paso
      1. abre C:\Program Files\PokerStrategy\PokerStrategy Elephant y busca postgresql-8.3 (no postgresql-8.3-int) o escribe directo C:\Program Files\PokerStrategy\PokerStrategy Elephant\postgresql-8.3.msi en mi computadora/tu explorador.
      2. en la instalacion elije Ingles->start->siguiente->siguiente-->siguiente.
      3. Configuracion del servicio:
      >Service name: PostgreSQL Database Server 8.3
      >Account name: postgres
      >Account domain: deja la que este por defecto.normalmente es el nombre de tu pc.
      >da click en crear la cuenta cuenta que sera usada por elephant.
      >en Initialise database cluster, cambia el "superusername" (esta postgres cambialo por postgres..escribe tu contraseña y da en finalizar.

      El problema es el mismo, al iniciar pone el mismo mensaje de q no se puede conectar con la base de datos.

      Eso si, no me apareció el paso 3 q pones de volver a poner el nombre de usuario y la contraseña
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Hola mostovax!

      Con la versión del Elephant v85 no deberías instalar por separado el postgres, simplemente se instala junto, en el mismo enlace mas abajo hay un video, esta en ingles pero es muy gráfico.

      Estas tratando de instalarlo por separado cierto?

      Saludos
      Jesús
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      Lo estaba tratando de instalar por separado porque al instalarlo según el manual mi problema es que cuando acaba la instalación del elephant (minuto 2.15 del védeo más o menos) cuando sale la ventana en la que te dice q tienes 21 días de prueba ( a mi me dice que tengo 8 pq ya lo tenía desde hace más tiempo la versión anterior)..... no me sale la ventana de instalación del posgres, simplemente se inicia el elephant y me dice que no se puede conectar con la base....

      Todo lo anterior lo he hecho con el posgres desinstalado y el elphant también

      es complicado esto del posgres,no??

      A ver si hubiera una solución....

      Muchas gracias
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      No es complicado, abre el Elephant y ve administrar base de datos y ve si la puedes crear desde ahi, si no, puedes instalar postgres 8.4, verifica si lo puedes bajar de aqui: http://www.icewalkers.com/Linux/Software/510900/PostgreSQL.html

      Saludos
      Jesus
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      En Administrar bases de datos, no me aparece ninguna base conocida, y si le doy a crear nueva base de datos me aparece localhost-elephantdb en bases de datos configuradas, pero al darle a aceptar me aparece otra vez el mensaje " no se pudo conectar con las base de datos. Asegurate de PostgresSQl funciona y que la configuración es correcta"

      Pruebo entonces a descargar el POsgres del link q me facilitas e instalarlo directamente?

      Gracias
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Donde diste en crear base de datos, me podrias poner una captura de pantalla con esta parte por favor?

      Saludos
      Jesus
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      Claro!!



      y muchas gracias por las molestias!!
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Ok, ahi le das en nueva, y que te aparece?...

      Saludos
      Jesus
    • mostovax
      mostovax
      Bronce
      Registro: 02-18-2010 Artículos: 249
      Pues al darle a nueva me aparece esto.



      y si le doy a aceptar me salta este error....



      y este error está en tu lista de preguntas frecuentes sobre el PosgresSQL, por eso que en uno de mis anteriores Post había seguido los pasos que tu indicaste para volver a instalarlo, pero luego me apuntaste que con esta versión de elephant no había que instalarlo por separado.
    • Jesus80
      Jesus80
      Bronce
      Registro: 11-15-2007 Artículos: 62.536
      Hola mostovax!

      Estas seguro que el nombre de usuario es "elephant" ? Muchas veces es "postgres", probablemente de ahi venga el error, estos datos los debiste meter tu durante la instalacion.

      Saludos
      Jesus
    • 1
    • 2